Arduino first steps: Unterschied zwischen den Versionen

Aus www.wiki.ardumower.de
Wechseln zu: Navigation, Suche
Zeile 65: Zeile 65:
 
  Now you can try to upload the [http://wiki.ardumower.de/index.php?title=Ardumower_PCB Ardumower code] the same way as you uploaded the blink example!
 
  Now you can try to upload the [http://wiki.ardumower.de/index.php?title=Ardumower_PCB Ardumower code] the same way as you uploaded the blink example!
  
<h3></h3>
+
&nbsp;
<h3></h3>
+
&nbsp;
<h3></h3>
+
&nbsp;
 +
&nbsp;
 +
&nbsp;

Version vom 24. November 2014, 12:26 Uhr

If you have never worked with Arduino before, this page describes how to start with your Arduino that you can purchase via the shop Shopping.png.


All you need to 'upload' the example code to your Arduino is:

  • One Arduino Nano (or Arduino Mega2560)
  • One USB cable
Arduino nano usb cable.jpg


1. Attach the Arduino to your computer

Using an USB cable, attach the Arduino (Arduino Nano or Arduino Mega) to your computer as shown below.

2. Download

Click here to download the Arduino development software (v1.5.8) to your computer 
(Windows users should download the 'Installer' version on that page):
Arduino symbol small.jpg  

3. Install

After the download completed, install the Arduino development software on your computer:
For Windows users, double click the downloaded file ('arduino-1.5.8-windows.exe') in your
Windows file explorer to run the installation.

4. Run

After the installation completed, run the Arduino development software on your computer 
by double clicking the 'Arduino' symbol on your Windows desktop.
Arduino start symbol small.jpg

5. Choose blink example

After the Arduino development software has started, choose the menu, 
and click on 'File->Examples->Basics->Blink'. This will load the Arduino blink example.
Arduino ide blink example.jpg

6. Choose correct board type

Via the menu, click on 'Tools->Board->Arduino Nano' to choose your Nano board 
(or Arduino Mega 2560 if you want to use a Mega board). 
Arduino ide choose board.jpg

7. Choose correct USB serial port

Via the menu, click on 'Tools->Port', and choose the detected USB serial port.
Arduino ide choose port.jpg

8. Upload the blink example

Click on the 'Upload' symbol to upload the blink example to your Arduino. 
After the upload completed, your Arduino will start to blink!
Arduino ide upload.jpg
After the code is uploaded, your Arduino will start to blink:
Arduino nano blink.jpg

Congratulations!

You have just programmed your first Arduino!
Now you can try to upload the Ardumower code the same way as you uploaded the blink example!